Scheduled Maintenance - June 24th, 2025
Complete·Under maintenance

This maintenance has been completed successfully.

Wed, Jun 25, 2025, 05:13 AM
(2 months ago)
·
Affected components
API Requests
Webhooks
Dashboard
Moov.js
Payments
Integrations
Updates

Complete

This maintenance has been completed successfully.

Wed, Jun 25, 2025, 05:13 AM

In progress

Maintenance has started

Wed, Jun 25, 2025, 04:00 AM(1 hour earlier)

Scheduled

UPDATE: We have postponed this maintenance to June 24 due to recovery efforts related to the Google outage on June 12.

We will perform infrastructure upgrades to the Moov platform during our regular maintenance window on Tuesday, June 24, from 11:00 pm to 1:00 am CT. These improvements will enhance platform performance and reliability, delivering a better experience for you and your customers as you grow. During the upgrades, the Moov Dashboard, API, and related services may be unavailable for up to 30–45 minutes of the maintenance window. Transactions that fail during this period will not be queued for later. We will monitor our systems closely throughout the maintenance and work to minimize service disruption. All services will resume normal operation once maintenance is complete.

For status updates, visit https://status.moov.io. If you have questions or experience issues after the migration, please contact our support team at help@moov.io. Thank you for your patience while we implement these important platform updates.

Fri, Jun 13, 2025, 01:33 PM(1 week earlier)

Scheduled

UPDATE: We have postponed this maintenance to June 24 due to recovery efforts related to the Google outage on June 12.

We will perform infrastructure upgrades to the Moov platform during our regular maintenance window on Tuesday, June 24, from 11:00 pm to 1:00 am CT. These improvements will enhance platform performance and reliability, delivering a better experience for you and your customers as you grow. During the upgrades, the Moov Dashboard, API, and related services may be unavailable for up to 30–45 minutes of the maintenance window. Transactions that fail during this period will not be queued for later. We will monitor our systems closely throughout the maintenance and work to minimize service disruption. All services will resume normal operation once maintenance is complete.

For status updates, visit https://status.moov.io. If you have questions or experience issues after the migration, please contact our support team at help@moov.io. Thank you for your patience while we implement these important platform updates.

Fri, Jun 13, 2025, 01:00 PM(33 minutes earlier)