Business account creation
Resolved·Degraded performance

The team has resolved the issue and account creation is functioning as expected.

Thu, May 22, 2025, 09:01 PM
(3 months ago)
·
Affected components
Dashboard
Updates

Resolved

The team has resolved the issue and account creation is functioning as expected.

Thu, May 22, 2025, 09:01 PM

Monitoring

We identified a problem that temporarily prevented the creation of new business accounts through the Moov dashboard. Account creation via API was unaffected.

Thu, May 22, 2025, 08:57 PM